Elastix Project
Project: RSS

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000304 [Module : Call Center] major always 2010-04-27 18:36 2010-04-28 18:30
Reporter fmvillares View Status public  
Assigned To a_villacis
Priority normal Resolution no change required  
Status resolved   Product Version
Summary 0000304: Call center not getting calls in queues
Description After creating a queue, agent, login, etc and with elastix dialer working with admin (elastix 456 pass) user with no errors in log i´ve logged in an agent the agent gets logged music on hold is there etc...firefox screen is waiting for a call to come...but when i make a call to that queue the client gets the music and announce as i load in the config (you re the first person in line....) but never got passed to the agent...both of them gets stuck there...
same issue with predictive dialer and different queue.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

SYSTEM WARNING: Creating default object from empty value

related to 0000308resolveda_villacis Interfaz de creación de agente debe ofrecer agregarlos a alguna cola 
related to 0000302resolveda_villacis Breaks option in call center agent screen not working 

-  Notes
(0001208)
a_villacis (developer)
2010-04-28 12:07

Is this test performed with incoming calls, or outgoing calls?

If I understand correctly, the incoming call stays stuck in the queue, even though the agent seems to be free. Is this what is going on? Could you please post the output of "agent show" and "queue show" from the Asterisk console when the situation happens?
(0001221)
fmvillares (reporter)
2010-04-28 16:19

agent 100 is logged in correctly in agent console (firefox) calling to queue 300 in other phone and call never gets in
outputs ....clearly agent is not logged in...

voipinx*CLI> queue show
300 has 1 calls (max 4) in 'rrmemory' strategy (1s holdtime, 2s talktime), W:0, C:1, A:1, SL:100.0% within 60s
   No Members
   Callers:
      1. SIP/103-00000006 (wait: 0:09, prio: 0)

default has 0 calls (max unlimited) in 'ringall' strategy (0s holdtime, 0s talktime), W:0, C:0, A:0, SL:0.0% within 0s
   No Members
   No Callers

voipinx*CLI> agent show
100 (Fernando) logged in on SIP/100-00000007 is idle (musiconhold is 'default')
1 agents configured [1 online , 0 offline]

voipinx*CLI>
(0001222)
a_villacis (developer)
2010-04-28 16:45

Please verify that Agent/100 has been actually added as a member of queue 300 on the FreePBX interface. A single agent might be a member of multiple queues, or none at all.
(0001224)
fmvillares (reporter)
2010-04-28 17:39

100 is added from the beginning in dymanic agents of freepbx 2.7 as always...

i deleted and recreate the queue and agent

same outputs cant get into the agent screen with the call in the queue...

voipinx*CLI> agent show
100 (Fernando) logged in on SIP/100-0000000a is idle (musiconhold is 'default')
1 agents configured [1 online , 0 offline]

voipinx*CLI>

voipinx*CLI> queue show
300 has 1 calls (max 4) in 'rrmemory' strategy (0s holdtime, 0s talktime), W:0, C:0, A:0, SL:0.0% within 60s
   No Members
   Callers:
      1. SIP/103-00000009 (wait: 2:42, prio: 0)

default has 0 calls (max unlimited) in 'ringall' strategy (0s holdtime, 0s talktime), W:0, C:0, A:0, SL:0.0% within 0s
   No Members
   No Callers

voipinx*CLI>

if i log in in the call manually with 300* and the agent number i can get all the calls instantly into the queue...the issue is only in the call center module not the acd or queue
(0001225)
a_villacis (developer)
2010-04-28 17:51

Currently Call Center does not support dynamic agents.

For agents to be used by Elastix Call Center, they must be static agents defined in agents.conf. It is necessary to add them to the static agent list in the queue definition in FreePBX, with the syntax A100 (or A### for the required agent number). These agents will then be visible in the output of "queue show" and the dialer will know that such agents are available.

The Agents interface in the Call Center web interface adds every defined agent to the agents.conf file automatically. The administrator then needs to add these agents to the queue definition in FreePBX with the syntax indicated above.
(0001226)
fmvillares (reporter)
2010-04-28 18:15

yeap....that was it...i assume by mistake that the behaviour was following the logic of freePBX...and of course dynamic and statis agents in 2.5 was that way...and in 2.7 the correct way was in dynamic...but the behaviour was the same as before...thanx alex...not a bug...but please document this behaviour for 2.7...not use dynamic...use agents as before...
(0001229)
a_villacis (developer)
2010-04-28 18:30

Not a CallCenter bug by itself, but CallCenter needs to be checked against FreePBX 2.7+ .

- Issue History
Date Modified Username Field Change
2010-04-27 18:36 fmvillares New Issue
2010-04-27 18:36 fmvillares Elastix version => 2.0 RC2
2010-04-27 19:52 bmacias Assigned To => a_villacis
2010-04-27 19:52 bmacias Status new => assigned
2010-04-28 12:07 a_villacis Note Added: 0001208
2010-04-28 16:19 fmvillares Note Added: 0001221
2010-04-28 16:45 a_villacis Note Added: 0001222
2010-04-28 17:39 fmvillares Note Added: 0001224
2010-04-28 17:51 a_villacis Note Added: 0001225
2010-04-28 17:58 a_villacis Relationship added related to 0000308
2010-04-28 18:15 fmvillares Note Added: 0001226
2010-04-28 18:30 a_villacis Note Added: 0001229
2010-04-28 18:30 a_villacis Status assigned => resolved
2010-04-28 18:30 a_villacis Resolution open => no change required
2010-04-28 18:31 a_villacis Relationship added related to 0000302


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker