Elastix Project
Project: RSS

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001485 [Elastix distro] Other Elastix GUI Issues minor always 2013-02-22 08:34 2013-10-14 11:28
Reporter kbish View Status public  
Assigned To a_villacis
Priority normal Resolution fixed  
Status resolved   Product Version 2.4.0-rc2
Summary 0001485: Dashboard High CPU
Description Dashboard applet cause High CPU Note: 0000100%
Additional Information 24999 asterisk 16 0 48252 27m 5756 R 32.6 1.4 0:41.50 httpd
25003 asterisk 16 0 44744 24m 5504 S 29.3 1.2 0:40.01 httpd
25002 asterisk 16 0 44972 23m 4952 S 29.0 1.2 0:38.27 httpd
 3644 asterisk 15 0 70576 35m 10m S 1.0 1.8 5:59.03 asterisk
Tags No tags attached.
Attached Files png file icon Capture du 2013-08-26 12:20:42.png [^] (26,744 bytes) 2013-08-26 05:23

- Relationships

-  Notes
(0006585)
a_villacis (developer)
2013-07-01 11:00

Please update to the latest Elastix packages from the stable repository (yum update elastix*) and try to reproduce the issue.
(0006755)
mikovh (reporter)
2013-08-26 05:21
edited on: 2013-08-26 05:24

with the latest version, there is still the same problem with CPU and Ram usage.
Dashboard displays high cpu peeks and high ram usage. Moreover, the swap seems to be never used.

Using htop or top command, I get mainly two process with relevant values:

  636 asterisk 15 0 280m 21m 4128 S 0.0 1.1 0:01.25
httpd

  603 root 21 -4 12700 816 420 S 0.0 0.0 0:00.57 udevd
  1 root 15 0 10368 708 596 S 0.0 0.0 0:00.78 init

                         
I don't have any brute force or any attacks in logs which correspond to high cpu and ram peeks period.

(0006846)
cfapress (reporter)
2013-09-17 08:36

I'm reporting that I have the same issue: CPU graph reporting high usage when in reality the CPU isn't used at all. It's almost as if the CPU graph is reporting the unused CPU cycles, not the used ones.

Here are my various elastix package versions:
 elastix 2.4.0 2
     elastix-asterisk-sounds 1.2.3 1
     elastix-system 2.4.0 8
     elastix-email_admin 2.4.0 3
     elastix-addons 2.4.0 3
     elastix-framework 2.4.0 9
     elastix-fax 2.4.0 2
     elastix-security 2.4.0 4
     elastix-reports 2.4.0 4
     elastix-a2billing 1.9.4 5
     elastix-vtigercrm 5.2.1 7
     elastix-my_extension 2.4.0 2
     elastix-im 2.4.0 2
     elastix-portknock 0.0.1 0
     elastix-firstboot 2.4.0 1
     elastix-agenda 2.4.0 8
     elastix-pbx 2.4.0 7
     elastix-extras 2.4.0 1

I just ran a yum update and the problem persists.

The computer is a Dual Core Pentium E2160
(0006855)
ss4sgoku (reporter)
2013-09-18 22:53

hi im having the same issue today 2013-09-18 i made a fresh install of 2.4 and the dashboard and everything was fine but after i made the update in the dashboard the cpu goes to 100% but the system didnt use anything , when i reload/update the cpu-ram-swap the thing goes to the real use. im running in a r710.... xeon etc etc.... i made the instalation twice just to know
(0006863)
cfapress (reporter)
2013-09-19 08:45

I agree with the prior note ... I noticed that when loading the Dashboard from an initial login or by clicking the 'Dashboard' link the CPU graph reads high utilization. However, if I click on the refresh button in only the System Resources widget the utilization reports a proper level (usually around 0%).
(0006868)
a_villacis (developer)
2013-09-19 10:21

Just to clear something up. Are we all talking about the same applet here?

The original reporter just posted what appears to be an extract from the "top" output. From this, I assume that something in the applet implementation caused excessive *real* cpu use.

mikovh reports weird display results from the "Performance Graphic" applet. This might be nothing more than an artifact of sampling, since the applet is only displaying the content of a database filled by /usr/local/elastix/sampler.php .

cfapress and ss4sgoku report what appears to be a known issue in the "System Resources" applet. Prior to SVN commit #5311, contrary to what the user expects, the applet does *not* update in real time. Instead, the applet shows what the CPU load is at the moment it is first rendered. As this is frequently the moment all of the other applets are being rendered too, the applet ends up displaying 100% CPU use, even when the server returns to being idle. This has already been fixed in SVN and is currently scheduled for Elastix 2.5.
(0006869)
cfapress (reporter)
2013-09-19 11:14

OK, you have my issue correctly identified. I will await v2.5
(0006903)
a_villacis (developer)
2013-10-05 10:37

The package elastix-system-2.4.0-11 has been uploaded to the repositories. This package includes a rewritten implementation of the Dashboard. Please test this version and report whether it fixes the issue. I need a report from everyone, since there appear to be several problems at once.
(0006918)
ss4sgoku (reporter)
2013-10-08 22:45

it works :)
(0006920)
mikovh (reporter)
2013-10-09 02:33

it also works :)
(0006930)
a_villacis (developer)
2013-10-14 10:47

Reported as fixed by upgrade.

- Issue History
Date Modified Username Field Change
2013-02-22 08:34 kbish New Issue
2013-03-28 03:28 jun74 Issue Monitored: jun74
2013-07-01 11:00 a_villacis Note Added: 0006585
2013-07-01 11:00 a_villacis Status new => feedback
2013-07-01 15:58 bmacias Target Version => 2.5.0 beta
2013-07-02 17:12 achuto Issue Monitored: achuto
2013-08-26 05:21 mikovh Note Added: 0006755
2013-08-26 05:23 mikovh File Added: Capture du 2013-08-26 12:20:42.png
2013-08-26 05:24 mikovh Note Edited: 0006755
2013-08-26 05:24 mikovh Note Edited: 0006755
2013-08-26 08:42 achuto Issue End Monitor: achuto
2013-09-17 08:36 cfapress Note Added: 0006846
2013-09-18 22:53 ss4sgoku Note Added: 0006855
2013-09-19 08:45 cfapress Note Added: 0006863
2013-09-19 10:01 a_villacis Status feedback => assigned
2013-09-19 10:01 a_villacis Assigned To => a_villacis
2013-09-19 10:21 a_villacis Note Added: 0006868
2013-09-19 10:21 a_villacis Status assigned => feedback
2013-09-19 11:14 cfapress Note Added: 0006869
2013-10-05 10:37 a_villacis Note Added: 0006903
2013-10-08 22:45 ss4sgoku Note Added: 0006918
2013-10-09 02:33 mikovh Note Added: 0006920
2013-10-14 10:47 a_villacis Note Added: 0006930
2013-10-14 10:47 a_villacis Status feedback => resolved
2013-10-14 10:47 a_villacis Resolution open => fixed
2013-10-14 11:28 achuto Fixed in Version => 2.5.0 beta


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker