Elastix Project
Project: RSS

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001381 [Module : Call Center] Call Center crash always 2012-10-02 07:26 2012-10-12 03:36
Reporter granapadana View Status public  
Assigned To a_villacis
Priority normal Resolution open  
Status feedback   Product Version 2.0
Summary 0001381: PHP Fatal Error
Description We install Elastix 2.3 on our server.
We updated Elastix on linux terminal with "yum update" command
When we install Call Center module (V2.1.99-4 alpha) on web interface and we token a error message on linux terminal and we could'br did anything on web interface Call Center module.

This Message : PHP Fatal Error: Cound'nt find implamentation for method ListaLlamasdas ::getiter ator in unknown online 0

We uninstalled V2.1.99-4 alpha and reinstalled V2.1.3-0 or V2.1.3-1 and it works without any error message, but we cant login agent console.
What must we do ? Please help us
Additional Information SYSTEM INFO
 Kernel
   Linux(x86_64)-2.6.18-308.13.1.el5

 Elastix
   elastix-2.3.0-7
   elastix-im-2.2.0-2
   elastix-fax-2.3.0-4
   elastix-agenda-2.3.0-7
   elastix-a2billing-1.9.4-5
   elastix-addons-2.3.0-6
   elastix-email_admin-2.3.0-6
   elastix-extras-2.2.0-1
   elastix-callcenter-2.1.99-4.alpha
   elastix-asterisk-sounds-1.2.3-1
   elastix-firstboot-2.3.0-7
   elastix-system-2.3.0-12
   elastix-security-2.3.0-5
   elastix-reports-2.3.0-4
   elastix-vtigercrm-5.2.1-6
   elastix-my_extension-2.2.0-6
   elastix-framework-2.3.0-11
   elastix-pbx-2.3.0-14

 RounCubeMail
   RoundCubeMail-0.3.1-12

 Mail
   postfix-2.3.3-2.3.el5_6
   cyrus-imapd-2.3.7-12.el5_7.2

 IM
   openfire-3.7.1-1

 FreePBX
   freePBX-2.8.1-14

 Asterisk
   asterisk-1.8.16.0-0
   asterisk-perl-0.10-2
   asterisk-addons-1.8.16.0-0

 FAX
   hylafax-4.3.10-2rhel5
   iaxmodem-1.2.0-2

 DRIVERS
   dahdi-2.6.1-4
   rhino-0.99.6-0.b2
   wanpipe-util-3.5.28-0
Tags No tags attached.
Attached Files log file icon dialerd.log [^] (510,447 bytes) 2012-10-02 11:55
zip file icon ssl_error_log.zip [^] (123,885 bytes) 2012-10-04 07:40

- Relationships
related to 0001094resolveda_villacis All Call In Call Center Call Detail Report show "abandoned" 

-  Notes
(0005408)
a_villacis (developer)
2012-10-02 12:52

In my email response, I also asked for the ls -l output. Please post that too.

The log only shows that one of the processes (AMIEventProcess) repeatedly fails to start. Try stopping the dialer process with "service elastixdialer stop", then
running the following:

su asterisk -c '/opt/elastix/dialer/dialerd -d'

Normally this should show no output. If there is output, please post a sample of it here.

Please also run "/usr/bin/php -v" and post the output. In a standard Elastix, this should show something like this:

PHP 5.1.6 (cli) (built: Jun 27 2012 12:21:13)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
    with Xdebug v2.0.5, Copyright (c) 2002-2008, by Derick Rethans
(0005409)
a_villacis (developer)
2012-10-02 13:07

You are getting hit by PHP bug #18556: https://bugs.php.net/bug.php?id=18556 [^]
(0005410)
a_villacis (developer)
2012-10-02 13:09

This is a manifestation of PHP bug #18556:

https://bugs.php.net/bug.php?id=18556 [^]
(0005411)
a_villacis (developer)
2012-10-02 14:07

Try this fix:

Make a backup of the file /etc/rc.d/init.d/elastixdialer .
Open /etc/rc.d/init.d/elastixdialer with any text editor.
Replace line 39 from this:
    daemon $"su $USUARIO -c \"$DIR_TRABAJO/$DAEMON\""
to this:
    NEWLANG=$LANG
    if [ "$LANG" == "tr_TR" -o "$LANG" == "tr_TR.UTF-8" ] ; then
        NEWLANG=en_US.UTF-8
    fi
    daemon $"su $USUARIO -c \"LANG=$NEWLANG $DIR_TRABAJO/$DAEMON\""
Save the file, and kill all remaining dialer processes with "killall -9 dialerd".
Run "/sbin/service elastixdialer restart".
(0005413)
granapadana (reporter)
2012-10-03 02:45

Good job Alex, Thank you very much.

We have type of change made in /etc/rc.d/init.d/elastixdialer file as you type and bug fixed. We dont think of the problem stems from the Turkish language.

But we cant still login in agent console.
Agents defined.
Ex. Agent Number:102 Name:102 Password:102 ECCP user defined automaticly when we try to login in agent console. We dont type ECCP user password in definig agent page. We dont type ECCP password in ECCP user edit page.

Bria softphone register for agent 102 on our server, we can see agent 102 online in operator panel.

When we try to login in agent console, at first we take "agent login terminated" or "proses stop" message, when try again er take "agent login failed" message.

When we check ECCP user pass. in call-center database they looks like :
agent table (eccp_password col) :89852d0d2f7f264e43073017fa11fc7e76ff81bc
eccp_authorized_clients table (md5_password col) :7e53aa92f7566f44f39f3f1842832581
They looks like difrent. This may be a problem or anything else ?
We read all bug reports and forum pages and we tried all of them.
be real glad if you help in this matter.
Thanks for your interest.
(0005414)
granapadana (reporter)
2012-10-03 02:57

queues_additional.conf file:

[191]
announce-frequency=0
announce-holdtime=no
announce-position=no
autofill=no
eventmemberstatus=no
eventwhencalled=no
joinempty=yes
leavewhenempty=no
maxlen=0
periodic-announce-frequency=0
queue-callswaiting=silence/1
queue-thereare=silence/1
queue-youarenext=silence/1
reportholdtime=no
retry=5
ringinuse=yes
servicelevel=60
strategy=ringall
timeout=15
weight=0
wrapuptime=0
member=Agent/102,0
member=Agent/104,0

extensions_custom.conf file :

[from-internal-custom]
exten => 1234,1,Playback(demo-congrats) ; extensions can dial 1234
exten => 1234,2,Hangup()
exten => h,1,Hangup()
include => agentlogin
include => conferences
include => calendar-event
include => weather-wakeup
include => automatic-msg

[automatic-msg]
exten => 191,1,Answer
exten => 191,n,Goto(ivr-3,s,1)
exten => 191,n,Hangup

[agentlogin]
exten => _*8888.,1,Set(AGENTNUMBER=${EXTEN:5})
exten => _*8888.,n,NoOp(AgentNumber is ${AGENTNUMBER})
exten => _*8888.,n,AgentLogin(${AGENTNUMBER})
exten => _*8888.,n,Hangup()
 
[mm-announce]
exten => 9999,1,Set(CALLERID(name)="MMGETOUT")
exten => 9999,n,Answer
exten => 9999,n,Playback(conf-will-end-in)
exten => 9999,n,Playback(digits/5)
exten => 9999,n,Playback(minutes)
exten => 9999,n,Hangup

[conferences]
;Used by cbEnd script to play end of conference warning
exten => 5555,1,Answer
exten => 5555,n,Wait(3)
exten => 5555,n,CBMysql()
exten => 5555,n,Hangup

[calendar-event]
exten => _*7899,1,Answer
exten => _*7899,2,Playback(${FILE_CALL})
exten => _*7899,3,Wait(2)
exten => _*7899,4,Hangup()

[weather-wakeup]
exten => *61,1,Answer
exten => *61,2,AGI(nv-weather.php)
exten => *61,3,Hangup
exten => *62,1,Answer
exten => *62,2,AGI(wakeup.php)
exten => *62,3,Hangup
; BEGIN ELASTIX CALL-CENTER CONTEXTS DO NOT REMOVE THIS LINE

[llamada_agendada]
exten => _X.,1,NoOP("NUMERO DE AGENTE -------------- ${EXTEN}")
exten => _X.,n,Dial(Agent/${EXTEN},300,t)

; END ELASTIX CALL-CENTER CONTEXTS DO NOT REMOVE THIS LINE
(0005423)
a_villacis (developer)
2012-10-03 15:00

Please post a zipped copy of /var/log/httpd/ssl_error_log of your server right after one failure to login.
(0005438)
granapadana (reporter)
2012-10-04 07:41

Hi Alex,
I added ssl_error_log file as zip format.
(0005439)
granapadana (reporter)
2012-10-04 08:15

there is a possibility that comes to mind,

we did not connected any analog line or PRI line or VOIP provider to our server yet.
we defined trunk but not work now.
for this reason we cant login agent console, may be ?
(0005444)
a_villacis (developer)
2012-10-04 11:19

The absence of trunks in your server should have no effect whatsoever in the issue of agent login.

Try the following. There is a script /opt/elastix/dialer/eccp-examples/agentlogin.php which is supposed to be an exercise of the agent login functionality for the dialer. You can use to test whether the problem really lies in the agent login, or elsewhere. To use:
- Open /opt/elastix/dialer/eccp-examples/agentlogin.php and replace the following strings:
    1064 --> extension you use to test the agent
    Agent/9000 --> Agent/102 (or the one you decide to use)
    gatito --> ECCP password for the agent (you can change the password in Agent Options-->Agents)
- Have your IP phone ready to receive a call
- Run the modified /opt/elastix/dialer/eccp-examples/agentlogin.php

What should happen is that the IP phone receives a call. The agent, upon answering it, should hear the agent password prompt. After dialing the password, the agent should hear that the login proceeds, and then hear music-on-hold.

A successful run of the program looks like this (press Ctrl-C to terminate):
[root@elx2 dialer]# ./eccp-examples/agentlogin.php
Connect...
SimpleXMLElement Object
(
    [status] => offline
)
Login agent
SimpleXMLElement Object
(
    [status] => logging
)
SimpleXMLElement Object
(
    [agentloggedin] => SimpleXMLElement Object
        (
            [agent] => Agent/9000
        )

)
[...after a while...]
SimpleXMLElement Object
(
    [agentloggedout] => SimpleXMLElement Object
        (
            [agent] => Agent/9000
        )

)

If the program fails to log the agent, please post the output of the program here.
(0005499)
granapadana (reporter)
2012-10-09 02:40

Hi Alex,

I applied the following steps

1- Deleted defined agents and eccp user in agent options web interface,
2- Checked database and i deleted defined agents in agent table,
3- Redefined again 102 agent,
4- Controled Bria, 102 extention registered,
4- Edited /opt/elastix/dialer/eccp-examples/agentlogin.php like your wroten,
5- Tested /opt/elastix/dialer/eccp-examples/agentlogin.php file,
6- File output like this:
Connect...
ECCPBadRequestException Object
(
    [message:protected] => Unauthorized
    [string:private] =>
    [code:protected] => 401
    [file:protected] => /var/www/html/modules/agent_console/libs/ECCP.class.php
    [line:protected] => 118
    [trace:private] => Array
        (
            [0] => Array
                (
                    [file] => /var/www/html/modules/agent_console/libs/ECCP.class.php
                    [line] => 288
                    [function] => send_request
                    [class] => ECCP
                    [type] => ->
                    [args] => Array
                        (
                            [0] => SimpleXMLElement Object
                                (
                                    [@attributes] => Array
                                        (
                                            [id] => 2
                                        )

                                    [getagentstatus] => SimpleXMLElement Object
                                        (
                                            [agent_number] => Agent/102
                                        )

                                )

                        )

                )

            [1] => Array
                (
                    [file] => /opt/elastix/dialer/eccp-examples/agentlogin.php
                    [line] => 10
                    [function] => getagentstatus
                    [class] => ECCP
                    [type] => ->
                    [args] => Array
                        (
                        )

                )

        )

)
7- Tryed to login in agent console web interface,
8- Taked same error message "Agent login terminated",
9- Tested again /opt/elastix/dialer/eccp-examples/agentlogin.php file,
10- File output like this:
Connect...
SimpleXMLElement Object
(
    [status] => offline
)
Login agent
SimpleXMLElement Object
(
    [status] => logged-out
    [failure] => SimpleXMLElement Object
        (
            [code] => 401
            [message] => Unauthorized agent
        )

)
(0005506)
a_villacis (developer)
2012-10-10 12:15

Did you change the ECCP password for the connection between attempts. The one that is defined as 'agentconsole' by default? The 401-Unauthorized agent in the second run is expected if the agent password is written incorrectly.

Try running the command with LANG=en_US.UTF-8 as follows, and report if it makes any difference:

[root@elx2 dialer]# LANG=en_US.UTF-8 ./eccp-examples/agentlogin.php
(0005512)
granapadana (reporter)
2012-10-11 02:54

Hi alex,

I didn't certainly change ECCP pasword.
and command output:
[root@elastix-server ~]# LANG=en_US.UTF-8 ./eccp-examples/agentlogin.php
-bash: ./eccp-examples/agentlogin.php: Böyle bir dosya ya da dizin yok

"Böyle bir dosya ya da dizin yok" means : "No such file or directory"
(0005514)
a_villacis (developer)
2012-10-11 10:02

Comment 0005506 assumed current directory was /opt/elastix/dialer. Try:

LANG=en_US.UTF-8 /opt/elastix/dialer/eccp-examples/agentlogin.php
(0005519)
granapadana (reporter)
2012-10-12 03:36

Dear Alex,

I logged on the agent console at the end of...
I continuous tryed with Bria but at this time I tested with Eyebeam and loged able to do.
What is the difference between Bria and Eyebeam, i dont know?
Both them i used the same configuration. I controled repeatedly.
No difference in any.
What do you think about ?

- Issue History
Date Modified Username Field Change
2012-10-02 07:26 granapadana New Issue
2012-10-02 07:26 granapadana Status new => assigned
2012-10-02 07:26 granapadana Assigned To => a_villacis
2012-10-02 11:54 granapadana Issue Monitored: granapadana
2012-10-02 11:55 granapadana File Added: dialerd.log
2012-10-02 12:52 a_villacis Note Added: 0005408
2012-10-02 12:52 a_villacis Status assigned => feedback
2012-10-02 13:07 a_villacis Note Added: 0005409
2012-10-02 13:07 a_villacis Status feedback => confirmed
2012-10-02 13:09 a_villacis Note Added: 0005410
2012-10-02 14:07 a_villacis Note Added: 0005411
2012-10-02 14:07 a_villacis Status confirmed => feedback
2012-10-03 02:45 granapadana Note Added: 0005413
2012-10-03 02:57 granapadana Note Added: 0005414
2012-10-03 15:00 a_villacis Note Added: 0005423
2012-10-04 07:40 granapadana File Added: ssl_error_log.zip
2012-10-04 07:41 granapadana Note Added: 0005438
2012-10-04 08:15 granapadana Note Added: 0005439
2012-10-04 11:19 a_villacis Note Added: 0005444
2012-10-09 02:40 granapadana Note Added: 0005499
2012-10-10 12:02 a_villacis Relationship added related to 0001094
2012-10-10 12:15 a_villacis Note Added: 0005506
2012-10-11 02:54 granapadana Note Added: 0005512
2012-10-11 10:02 a_villacis Note Added: 0005514
2012-10-12 03:36 granapadana Note Added: 0005519


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker